passengerのApacheモジュールがビルド出来なくて詰んでたメモ

CentOS5.7 x86_64環境において
passenger3でapacheモジュールを作ろうとすると
curl-devをインストールしているにも関わらずCurlライブラリがないと怒られる

$gem i passenger
$passenger-install-apache2-module
...
Curl development headers with SSL support... not found

原因はCurlではなくて他のパッケージが足りなかったのが原因でした
以下のパッケージをインストールして無事ビルド完了

$ sudo yum install krb5-devel libidn-devel

これを解決するのに半年かかったとかもうね…

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください